Users
It is possible since version 2.21.6 and onwards to log in to node with portal user.
The user in the node will get the same global rights that the user has to the node's root directory in the portal.
Local schedules
Schedule scripts are not synchronized from node to portal. If local schedule should be used in node/portal the script needs to be created in both Web Port systems.
In System settings/Server/Schedule there is a setting for how often Web Port will synchronize local schedules in the background. Default is 10 minutes.
When opening a local schedule in the portal the latest synchronized value is shown and a background read operation is started to update the values.
Synchronization problems
If there are problems synchronizing files, trends or values, check that the portal has the same or newer version of Web Port compared to the node, and that the system times are synchronized in the same time zone and time format.
If nodes connect correctly to the portal (green connection) but no synchronization takes place, it may be due to network security systems (such as Web Application Firewalls, WAF) blocking certain traffic.
Possible causes:
-
Blocking of certain content types (e.g.
application/octet-stream
) -
POST data or URL length exceeding allowed limits
-
Blocking due to attack signatures (e.g. SVG tags in the data)
-
Limitations on the number of parameters in API requests
Solution:
Contact your IT department and ask them to check if any traffic from the node is being blocked by firewalls or security systems. The following may be needed:
-
WAF exceptions for specific URIs (e.g.
/node/upload/*
) -
Adjusting allowed POST sizes or URL lengths
-
Allowing specific content types
It may also be helpful to provide a specification of the data types being sent from the node, to assist IT in allowing the correct traffic.
This information can be found under: System Settings → Activity Log → Debug Log, if you enable "debug mode" under the node settings on the node.
Certificate problems in portal
If the Portal has e.g. a self-signed certificate the node will not allow connection to the portal. This can be turned off under System settings/Communication/Drivers/DrvNode and check Disable certificate validation.
Resetting node
Resetting a node in the portal works like this:
The portal sends a list of all the node files it has. This list is matched with the files available on the node and a list of changed files (new, changed, removed) is created. The files in this list is sent to the portal, and the no longer valid ones are removed from the portal.
Alarm and trend history, as well as set times for these, are not touched. If you want to re-sync historic data, change current trend synchronization <- to the current time.
Communication information
The node and the portal will set status Connecting if no contact for more than 60 seconds.
New connection attempts are normally done every second (if no ongoing transactions).
If a node is removed in the portal, it will reconnect from the node and will appear again within 60 seconds.
Changing tag prefix
Tag prefix can be changed until the node has been activated in the portal. To change it after it has already been activated, the node needs to be removed from the portal. It will be reconnected again and a new tag prefix can be set before activating.
Editing Pageinfo/Metadata on Node/Portal
When editing page info and metadata across your Node and Portal, it’s important to understand how the syncing process works:
- Initial Sync: When you activate a Node for the first time, its page info and metadata are automatically synced to the Portal.
- Subsequent Changes on the Node: If you update the page info or metadata on the Node after the initial sync, these changes will not be reflected on the Portal unless the Node is removed from the Portal and re-added.
- Edits on the Portal: Any changes made directly to the page info or metadata on the Portal will remain exclusive to the Portal and won’t sync back to the Node.